Turn signals not working??????


Go Back   Jeep Cherokee Forum > Jeep Cherokee Forums > Jeep Cherokee Stock Technical Forum


CherokeeTalk.com is the premier Chrysler Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-04-2010, 11:45 AM   #1
jeepgirl1010
Newbie
Feedback Score: 0 reviews
 
jeepgirl1010's Avatar
 
Join Date: Jun 2010
Posts: 4
Default Turn signals not working??????

Okay so here is my issue i have a 1998 jeep Cherokee sport 4x4 4L straight 6

My problem is my turn signals don't work at all but the hazards do..(go figure) my friend is a car junkie and has been helping me out...we went to the jeep dealer service center and it was a 100 dollars an hour to just figure out what was wrong then when they finally tell us whats going on it came out to 1000$
(i don't know about the rest of you but i don't have that kind of money to spend on a junk car)..so the service dept gave us a list of things that could be wrong ..and we were going to replace them ourselves. well we replace the turn signal switch (oem) the clock spring (oem) the flasher unit and the gauge cluster plugs (oem) and i still have this issue ...the only thing that worked was that it fixed my horn and cruise control...and we checked all the fuses everywhere and all are in good condition and replaced the bulbs in the gauge unit in the dash....me and my friend cant figure it out ..and we would like a push in the right direction without paying a arm and leg to replace everything at a dealer.....HELP ASAP


jeepgirl1010 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-04-2010, 11:49 AM   #2
BACKWOOD
Veteran
Feedback Score: 0 reviews
 
BACKWOOD's Avatar
 
Join Date: Apr 2009
Location: Kenosha, Wisconsin
Posts: 1,402
Default

how is the condition of the sockets that the bulbs go into? are any of the bulbs blown out?
__________________
TRAIL RIG:
89 Cherokee - 8.5" & 35's.
Front Aussie Locker and Chromoly shafts.
ARB front bumper & JCR rear.
Advanced Adapters SYE.
JCR 1 Ton OTK steering and T&T Customs Trac bar.

Project Goldielox
http://www.cherokeetalk.com/forum/f2...oldielox-8054/
BACKWOOD is offline   Reply With Quote
Old 06-04-2010, 12:00 PM   #3
jeepgirl1010
Newbie
Feedback Score: 0 reviews
 
jeepgirl1010's Avatar
 
Join Date: Jun 2010
Posts: 4
Default

nope we checked all of them and every thing was fine and working kinda scary though after i got the jeep and took the gauges dash off there were bulbs missing from check engine airbag and check gauges ..i just got the jeep in feb of this year too.
jeepgirl1010 is offline   Reply With Quote
Old 06-04-2010, 12:05 PM   #4
BACKWOOD
Veteran
Feedback Score: 0 reviews
 
BACKWOOD's Avatar
 
Join Date: Apr 2009
Location: Kenosha, Wisconsin
Posts: 1,402
Default

was just wondering, my rear quarter panel was rotted and mud would fling up at the bulb sockets. the bulbs were not blown but when i tried to remove the bulb the glass slid out of the contact and the contact got stuck in the bulb socket.

I cant seem to remember how i fixed mine, i had the same problem with the bulbs only working with the hazards
__________________
TRAIL RIG:
89 Cherokee - 8.5" & 35's.
Front Aussie Locker and Chromoly shafts.
ARB front bumper & JCR rear.
Advanced Adapters SYE.
JCR 1 Ton OTK steering and T&T Customs Trac bar.

Project Goldielox
http://www.cherokeetalk.com/forum/f2...oldielox-8054/
BACKWOOD is offline   Reply With Quote
Old 06-04-2010, 12:39 PM   #5
jeepgirl1010
Newbie
Feedback Score: 0 reviews
 
jeepgirl1010's Avatar
 
Join Date: Jun 2010
Posts: 4
Default

Hmm il have to check into that ..i was also wondering if there was a short in a wire somewhere cause both fronts and backs dont work and maybe there is a connection to the battery somewhere that just is worn or something ..its very stressful cause this is my main transportation..and i need turn signals lol
jeepgirl1010 is offline   Reply With Quote
Old 06-05-2010, 08:52 AM   #6
jerman75
Veteran
Feedback Score: 0 reviews
 
jerman75's Avatar
 
Join Date: Apr 2009
Location: Medina, New York
Posts: 1,174
Default

if the hazards work but flashers dont then it is unlikely a short in the wire.
jerman75 is offline   Reply With Quote
Old 06-05-2010, 10:47 AM   #7
Fidishund
Senior Member
Feedback Score: 1 reviews
 
Fidishund's Avatar
 
Join Date: Feb 2010
Location: Morrisville, PA
Posts: 687
Default

sounds like wiring issue maby a ground disconnected somewhere
__________________
Wheelin = Break it ,Fix it, Make it Better


" I'd like to view the world from another Angle" Jewl

"Wheelin Gives me that View" ME
Fidishund is offline   Reply With Quote
Old 06-05-2010, 10:48 AM   #8
Fidishund
Senior Member
Feedback Score: 1 reviews
 
Fidishund's Avatar
 
Join Date: Feb 2010
Location: Morrisville, PA
Posts: 687
Default

Quote:
Originally Posted by jerman75 View Post
if the hazards work but flashers dont then it is unlikely a short in the wire.
there on 2 seprate circts.. so yes the flashers could work and flashers not
__________________
Wheelin = Break it ,Fix it, Make it Better


" I'd like to view the world from another Angle" Jewl

"Wheelin Gives me that View" ME
Fidishund is offline   Reply With Quote
Old 06-06-2010, 09:13 AM   #9
jeepgirl1010
Newbie
Feedback Score: 0 reviews
 
jeepgirl1010's Avatar
 
Join Date: Jun 2010
Posts: 4
Default

Thank you guys so much for you help im going to check out the wiring on the dam thing...you guys rock


il let you know what happens
jeepgirl1010 is offline   Reply With Quote
Old 08-08-2010, 12:18 PM   #10
kslongrider
Newbie
Feedback Score: 0 reviews
 
Join Date: Aug 2010
Posts: 3
Default

So did you ever get it figured out??
kslongrider is offline   Reply With Quote
Old 10-27-2010, 09:37 AM   #11
babykinz
Newbie
Feedback Score: 0 reviews
 
Join Date: Oct 2010
Location: lillian
Posts: 1
Default

Just wanted to Post here , even though this was an old question as its still active in a Google Search.

This same thing happened to a 1996 Jeep Grand Cherokee we recently bought.
No turn signals but the emergency flashers did work.

We checked and replaced the relays, checked the fuses , replaced the whole turn signal part that is connected to the steering column, nothing worked.
Finally my husband decided to check every single fuse there was... Low and behold...there was a small tiny fuse in the back the fuse panel ( the one on the passengers side panel ) that did it. It also brought back to life the navigation center.

So to anyone with this problem, please check ALL the fuses, not the the ones that are marked for the turn signals.

I hope this helps.
babykinz is offline   Reply With Quote
Old 10-29-2011, 09:14 AM   #12
skycladlaw
Experienced
Feedback Score: 0 reviews
 
skycladlaw's Avatar
 
Join Date: Oct 2011
Location: Somerville, NJ
Posts: 189
Default

I hope I am not stealing a thread here. When I turn my steering wheel slightly to either side they turn on the signal, it seems it is almost like I have to force the signal arm into the position. Don't want to force it.

Dust, bad connection, just tired?


__________________
It's not when you finish...
It's the path you make...

Go STEELERS!!!!!!
skycladlaw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Go Back   Jeep Cherokee Forum > Jeep Cherokee Forums > Jeep Cherokee Stock Technical Forum
Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
I cant turn! XJPioneer Jeep Cherokee Modified Technical Forum 11 05-20-2010 02:13 AM
bad turn signals GardenGnome07 Jeep Cherokee Stock Technical Forum 4 09-06-2009 09:16 PM
Ahhhhh won't turn over XJeezy Jeep Cherokee Stock Technical Forum 4 04-24-2009 07:01 PM
No engine turn over GardenGnome07 Jeep Cherokee Stock Technical Forum 9 02-17-2009 11:14 AM
No flashers unless I have the right turn signal switched on??? firehawk Jeep Cherokee Stock Technical Forum 8 11-16-2008 06:54 PM




All times are GMT -6. The time now is 04:09 AM.



Copyright ©2000 - 2014, Jelsoft Enterprises Ltd
-->

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.6.0