+Crank, No start... CKPS not at fault


Go Back   Jeep Cherokee Forum > Jeep Cherokee Forums > Jeep Grand Cherokee Technical Forum

CherokeeTalk.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-10-2017, 11:26 PM   #1
DaingMaing
Medicated and Dedicated
Feedback Score: 0 reviews
 
DaingMaing's Avatar
 
Join Date: Apr 2010
Location: Telluride, Crawlerado
Posts: 934
Garage
Default +Crank, No start... CKPS not at fault

I have fuel pressure, new CKPS, switched out the Cam Shaft position sensor with a known good one.

I started it the other night to charge up the batteries, and shut it down within a couple of minutes; then decided that three or four mins wasn't enough. It didn't start again after that. I have fuel at the rail, and can smell it after 30 seconds of cranking. I don't have a pressure gauge, and thought that perhaps there was water in the lines. After a few hours of HEET working into the fuel, it still wont start.

What's left to check on?

Ignition coil?

PCM?

I will be checking on the spark in the morning, and gonna try changing out the PCM with a backup.


__________________
- March 2016 - Modified Grand Cherokee of The Month - October 2013 -


Last edited by DaingMaing; 01-10-2017 at 11:47 PM.
DaingMaing is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-11-2017, 12:42 AM   #2
4.3L XJ
Veteran
Feedback Score: 0 reviews
 
4.3L XJ's Avatar
 
Join Date: Dec 2008
Location: Chico, CA
Posts: 7,639
Garage
Default

Do you have spark?
__________________
230 hp 4.3L Chevy
Built 4L60E with manual lockout
Atlas 4 speed
Griffin radiator
On board air
Warn 9.5ti on custom bumper
7.5" RE front and bastard pack rear on custom long arms
31 gal. gas tank
4.3L XJ is offline   Reply With Quote
Old 01-11-2017, 11:36 AM   #3
DaingMaing
Medicated and Dedicated
Feedback Score: 0 reviews
 
DaingMaing's Avatar
 
Join Date: Apr 2010
Location: Telluride, Crawlerado
Posts: 934
Garage
Default

We have a Solid, Steady spark at the ignition coil. There is gas at the rail. It turns over and sounds like it is slightly off. It wants to start but is out of time. I reset the PCM by touching the + & - together for 30 seconds. The ASD is not active. The fuel pump kicks on and appears to build pressure. She should start but wont.

I'll be digging out the back up PCM and see if that does anything. BTW, No check Engine Lights nor Codes.


Only thing I can think of is a bad fuel pump, cap/rotor, PCM, or ice in the lines. Any one else got an idea or three?
__________________
- March 2016 - Modified Grand Cherokee of The Month - October 2013 -


Last edited by DaingMaing; 01-11-2017 at 11:58 AM.
DaingMaing is offline   Reply With Quote
 
Old 01-11-2017, 01:44 PM   #4
4.3L XJ
Veteran
Feedback Score: 0 reviews
 
4.3L XJ's Avatar
 
Join Date: Dec 2008
Location: Chico, CA
Posts: 7,639
Garage
Default

Did you check the fuse for that ASD?
__________________
230 hp 4.3L Chevy
Built 4L60E with manual lockout
Atlas 4 speed
Griffin radiator
On board air
Warn 9.5ti on custom bumper
7.5" RE front and bastard pack rear on custom long arms
31 gal. gas tank
4.3L XJ is offline   Reply With Quote
Old 01-11-2017, 08:38 PM   #5
Gluckmysock
Hack Tech Extraordinaire!
Feedback Score: 0 reviews
 
Gluckmysock's Avatar
 
Join Date: May 2013
Location: Uniontown, PA
Posts: 7,265
Garage
Default

When mine pulled the crank no start fit. It turned out to be the cam sensor module in the distributor. It also didn't light the dash indicator lights. and I could not pull the codes. Replaced the sensor and it started right up, well sort of. it was flooded from all the cranking and smoked like a dragon for a few minutes. then cleaned up and ran good.
__________________
1996 Cherokee classic. 100k Miles, I6 HO, AW4, Np242, D30/C8.25 3.5" RE lift
My build thread: Gemini
NP242 Hack n Tap (SYE) Install
Common links: Budget MODS List And All You Ever Wanted to Know About an XJ

December 2013 Stock Class Cherokee of the month
May 2015 Modified Cherokee XJ of the Month
Gluckmysock is offline   Reply With Quote
Old 01-12-2017, 02:40 AM   #6
DaingMaing
Medicated and Dedicated
Feedback Score: 0 reviews
 
DaingMaing's Avatar
 
Join Date: Apr 2010
Location: Telluride, Crawlerado
Posts: 934
Garage
Default

Quote:
Originally Posted by Gluckmysock View Post
When mine pulled the crank no start fit. It turned out to be the cam sensor module in the distributor.
Yeah, I thought of that, and had a known good sensor when I replaced it about a year ago. That's the one in there now.

I'm thinking PCM, Ice in the Lines, fuel pump, or Bad Cap and rotor. The ones in there now are a bit chewed up. The rotor is rough, but I didn't think it was that bad enough to cause a no-start condition.


Quote:
Originally Posted by 4.3L XJ View Post
Did you check the fuse for that ASD?

Could it have blown and still allowed a start condition?

I figure it would have prolly not allowed a spark nor fuel if it had blown.

She's cranking like the timing is about 15-20* off; just wanting to start but cant, and you can smell the gas in the exhaust. I thought maybe a timing chain, but she's wanting to start. It's close at times


Thanks, I'll check it
__________________
- March 2016 - Modified Grand Cherokee of The Month - October 2013 -


Last edited by DaingMaing; 01-12-2017 at 02:52 AM.
DaingMaing is offline   Reply With Quote
Old 01-12-2017, 10:30 PM   #7
DaingMaing
Medicated and Dedicated
Feedback Score: 0 reviews
 
DaingMaing's Avatar
 
Join Date: Apr 2010
Location: Telluride, Crawlerado
Posts: 934
Garage
Default

Not the Rotor and cap...

It wants to start on the first turn, but then just stops and continues to turn... Gonna change out PCMs tomorrow and check that ASD fuse.. <fingers crossed>
__________________
- March 2016 - Modified Grand Cherokee of The Month - October 2013 -

DaingMaing is offline   Reply With Quote
Old 01-13-2017, 04:31 AM   #8
VaBeachMike
Senior Member
Feedback Score: 0 reviews
 
VaBeachMike's Avatar
 
Join Date: Sep 2016
Location: Old Beach in Virginia Beach, VA
Posts: 570
Garage
Default

Hard to believe with your knowledge you haven't solved this mystery! Good Luck and hopefully the next fix you try will get you running again.
__________________
February 2017 Modified Cherokee of the Month
Living the Good Life!
Zephyr (Beach Crawler) 2000 Sport 4.0-Born 8-99-Adopted 9-2013
VaBeachMike is offline   Reply With Quote
Old 01-13-2017, 12:45 PM   #9
DaingMaing
Medicated and Dedicated
Feedback Score: 0 reviews
 
DaingMaing's Avatar
 
Join Date: Apr 2010
Location: Telluride, Crawlerado
Posts: 934
Garage
Default

I changed the PCM this morning, and no change in status. Down to just a Fuel Pump or Ice in the Lines. Everything else is kosher, including ASD fuses and relay. Starting to look for a fuel pressure gauge and a warmer day to see if its just ice. This is really gonna suck if I have to change out the fuel pump in the dead of winter in the complex parking lot.
__________________
- March 2016 - Modified Grand Cherokee of The Month - October 2013 -


Last edited by DaingMaing; 01-13-2017 at 12:47 PM.
DaingMaing is offline   Reply With Quote
Old 01-13-2017, 11:48 PM   #10
DaingMaing
Medicated and Dedicated
Feedback Score: 0 reviews
 
DaingMaing's Avatar
 
Join Date: Apr 2010
Location: Telluride, Crawlerado
Posts: 934
Garage
Default

I have a fuel pressure gauge on the way. I still think it's ice in the lines, and i'm gonna put a second bottle of HEET into the gas tomorrow. Working hasn't allowed much time to work on it in the freezing cold this week. I think I have about another week before town has the lot plowed, and will tow if I don't move it. Looks like I may get some favorable temperatures on Saturday to try and start 'er up.

I don't like the idea of changing a fuel pump in the dead of January. Let alone the price tag.

If I have to, any one have a suggestion on which 'brand' to buy? Obviously I want OEM specs...
__________________
- March 2016 - Modified Grand Cherokee of The Month - October 2013 -

DaingMaing is offline   Reply With Quote
Old 01-17-2017, 11:12 PM   #11
DaingMaing
Medicated and Dedicated
Feedback Score: 0 reviews
 
DaingMaing's Avatar
 
Join Date: Apr 2010
Location: Telluride, Crawlerado
Posts: 934
Garage
Default

It twas ice in the lines. She chugged to life today after a second bottle of HEET and about an hour of time. I had to turn it over three or four times before the antifreeze got in there. I think I may have had ice form in the injectors somewhere. I could always get some gas at the schrader valve on the rail, but not start....

It might be possible that the gas companies are putting water in the gas to get the octane down to 85 out here in colorado; well, at least the cheaper companies may be. I had a full tank when she stopped running last week, and was really sweating having to replace the fuel pump in the dead of winter outside on the ice.

Now that I have a fuel pressure gauge, does any one know what a stock IL6 242 4.0L should have in the lines pressure wise?

Thanks for the help, and it prolly was a good exorcise in the troubleshooting list for the ZJ. Hopefully this may help someone else out at a later date.
__________________
- March 2016 - Modified Grand Cherokee of The Month - October 2013 -


Last edited by DaingMaing; 01-17-2017 at 11:16 PM.
DaingMaing is offline   Reply With Quote
Old 01-18-2017, 01:44 AM   #12
wjlizard
Veteran
Feedback Score: 0 reviews
 
wjlizard's Avatar
 
Join Date: Aug 2012
Posts: 3,404
Default

Glad you got it sorted out
__________________
Oct 2014 and Jan 2016 Modified Cherokee Of The Month
wjlizard is offline   Reply With Quote
Old 01-18-2017, 03:00 AM   #13
VaBeachMike
Senior Member
Feedback Score: 0 reviews
 
VaBeachMike's Avatar
 
Join Date: Sep 2016
Location: Old Beach in Virginia Beach, VA
Posts: 570
Garage
Default

Glad you got her going! What a PITA for you though.


Sent from my iPhone using Tapatalk
__________________
February 2017 Modified Cherokee of the Month
Living the Good Life!
Zephyr (Beach Crawler) 2000 Sport 4.0-Born 8-99-Adopted 9-2013
VaBeachMike is offline   Reply With Quote
Old 01-18-2017, 06:11 AM   #14
pizzaman3872
Veteran
Feedback Score: 1 reviews
 
pizzaman3872's Avatar
 
Join Date: Mar 2010
Location: haines city, florida
Posts: 2,911
Garage
Default

My book says 32-46psi

Sent from my Z959 using Tapatalk
__________________
JEEP= Just Enough Essential Parts
M.J.= MY JEEP
Jeep MJ Comanche 3in zone 3.55 gears f+r powerking tires 97 front clip and doors power windows and a/c that actually works lol.

gone=88 big orange
gone=99 red baby get er
build thread orangehttp://www.cherokeetalk.com/forum/f2...elivery-12335/

project Sunshine http://www.cherokeetalk.com/forum/f2...unshine-50577/
pizzaman3872 is offline   Reply With Quote
Old 01-20-2017, 05:55 PM   #15
Gluckmysock
Hack Tech Extraordinaire!
Feedback Score: 0 reviews
 
Gluckmysock's Avatar
 
Join Date: May 2013
Location: Uniontown, PA
Posts: 7,265
Garage
Default

At least 40psi


Gluckmysock is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Go Back   Jeep Cherokee Forum > Jeep Cherokee Forums > Jeep Grand Cherokee Technical Forum
Thread Tools
Display Modes




All times are GMT -6. The time now is 09:57 PM.



Copyright ©2000 - 2017, Jelsoft Enterprises Ltd
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.6.0