Jeep Cherokee Talk banner

1 - 16 of 16 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
99 xj 4.0L

well it's not the crank position senser thats $80 outa my pocket and it's staying on the jeep took me 3 hrs to put it on.. and not the pickup coil in the distributor.... next going to get a coil and see if that is it... I checked all the fuses all good..... anyone know what it might be I have been fighting this thing for 2 days spent about $200 so far. if anyone know let me know it's driveing me nuts this is my DD.
 

·
Registered
Joined
·
6,178 Posts
NSS? Im just throwing ideas out there, wait for somebody else to come out and add more. Also are you sure the CPS you bought is functioning properly? I have heard of them being defective out of box before. Aside from that start tracing your wire problem starting from the block.
 

·
Registered
Joined
·
606 Posts
Just went through this same thing on my 98 replaced same parts as you it was a bad computer mine was broke down going on 6 weeks.It runs great now you need to check all your wiring\connectors with a ommeter have you done a search on North American XJ Association lot of info over there.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
yep checked there got same thread going there I installed wifes 96 XJ cpu on my XJ and still had no spark gonna bring a meter home for the weekend and test wires and see if I can trace it down....installe new CPS, Coil, Pickup coil in distributor, wires, ca, and rotor still no fire and tested all fuses and relays...

very puzzleing...... confused LOL
 

·
Budget Master
Joined
·
1,145 Posts
spark plugs?
 

·
Registered
Joined
·
6,178 Posts
yep checked there got same thread going there I installed wifes 96 XJ cpu on my XJ and still had no spark gonna bring a meter home for the weekend and test wires and see if I can trace it down....installe new CPS, Coil, Pickup coil in distributor, wires, ca, and rotor still no fire and tested all fuses and relays...

very puzzleing...... confused LOL
It is confusing, I wish I could be of more help but I dont hear of this too much.
 

·
Registered
Joined
·
7 Posts
I installed wifes 96 XJ cpu on my XJ and still had no spark


Are the cpu the same part numbers? I believe the ASD ( auto shut down ) controls the spark coming from the cpu. to the distributor. If there is no signal coming from the CPS (which is new) the ASD pulls the ground from the cpu. Check to make sure that you have a good connection at the cps connector.
 

·
Web Wheeler
Joined
·
2,573 Posts
Yeah definitely get a voltmeter and start at the coil and start working your way back until you get a current.

I know it's not your NSS though because if it was, your jeep wouldn't turn over.

I had a weird problem where my jeep just randomly died and had no spark and it turned out to be the altenator. I don't know how a bad altenator can cause bad spark, but it did.
 
1 - 16 of 16 Posts
Top