Jeep Cherokee Talk banner

1 - 20 of 32 Posts

·
Registered
Joined
·
1,134 Posts
Discussion Starter #1
my sensor is just floating around the engine bay not connected to anything. does anyone know where its supposed to be?
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #2
is there another name for this sensor. im just going by the name on the tag. ive searched all over and the name doesnt come up anyplace. anyone have a link to a pdf manual for this 86?
 

·
Registered
Joined
·
608 Posts
A pic of the thing would help.
I don't have a link to a pdf, but I do have a manual I can scan diagrams and such from if needed...
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #4
ok i took pics today when i was replacing the clutch master cylinder and heater switch today.

 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #5
heres a much better pic


 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #7
I wonder if that was a sensor that was used in the 4.0 so they just left it alone in the 2.5's. Other then that I am pretty lost on this one, never seen that sensor before.
it goes to the cruise control box so i dont know. its a magnetic pickup for sure though. i was at the dealer today they had no clue either.the white tag in the pic says spark plug current sensor, warning this sensor must be attached to prevent engine damage" then something about see cruise control section of manual....
i geuss if someone else with a 86 2.5l with cruise control can locate the wires coming from the cruise control box then we might find out where this thing goes
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #9
Are you experiencing any problems?
yea the idle is rough, hard to tell how bad because i have a big exaust leak probably the manifold is cracked.it idles like its going to die sometimes too.o.d. says it has 170k on it. lots of stuff wrong with it. looks like it leaked alot of oil at one time guy said he fixed the valve cover gasket. i dunno. powersteering has big time shaft play and the belt isnt there anyways.clutch master cylinder just whent out second day owning it, then headlight switch, heater switch was already fried, alternator belt burned up and fell off last night. yea it has all the jeep issues ive hear of so far:)
i traded a 1996 hyundai accent with 142k for the jeep that i bought a year ago for 240 bucks so im happy. i love driving this in the snow!
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #11
So no issues to speak of? :D


Well concerning your idle issues, start with the exhaust leak/cracked manifold and work your way down from there.
is there a header out there for the 2.5? i hate cast stuff
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #13
IIRC borla makes one, but I know they are hard to come by.
oh geez borla so it cost a arm and a leg then. oops thats bassani,lol
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #15
Well they arent cheap by any means :D
i dont think a cracked mani is going to affect my idle since theres no post cat o2 sensor right? i used seafoam on it it didnt like the seafoam i had to try starting it for 20 mins.oil is still clean from the recent oil change so thats good. timing might be off or injectors might be nasty.no doubt some sensors probably bad .these are OBDI ecus? is there a self test code puller ?the key dance read the cel light or jump the scan port?
 

·
Registered
Joined
·
1,134 Posts
Discussion Starter #17
You need to invest in a voltmeter with your rig, no codes to read :D
so its not obd1 or obd0? and cant be scanned scan tool?
what year did they go to sefi(mpfi) from this tbi? might be worth switching intakes to that from junkyard stuff.or can you switch em.
 

·
Registered
Joined
·
307 Posts
well. that cruise is not even a factory part, and if your cruise doesn't work, yank it out and throw it away.

whatever that sensor is, it looks like it just hangs around a spark plug wire or something along those lines, and it's pretty halfass. I'm guessing the aftermarket cruise control box operates off of spark current which will tell it rpm's and allow it to adjust accordingly.

that said, it's a pile of crap that doesn't need to be there, and has nothing to do with your running issues.

if you need any 4 cylinder manifolds let me know, I've got quite a bit of 4 cylinder parts.
 

·
Registered
Joined
·
934 Posts
After reviewing the FSM for your year and engine, I can't find that sensor/2 wires anywhere. I've attached some GIF's of the Cruise circuit. Hope that helps. Like stated above, if it is an aftermarket unit...that sensor may not be required on your application.



 

·
Registered
Joined
·
334 Posts
I'm going x2 on it's an aftermarket cruise, it don't look stock. Picks up rpm from a spark plug wire.




Good luck....


Run a spark plug wire through the hole and see if your cruise starts to work.....​
 
1 - 20 of 32 Posts
Top