Jeep Cherokee Talk banner

1 - 9 of 9 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Purchased a 93 cherokee with the front end wrecked. It started and drove onto the trailer to haul it home. Needed a boost, bad battery. Replaced front fenders all front lights, grill, & hood. NEW BATTERY - now it won't turn over, doesn't even click. Will turn over if jumped across starter selenoid. Replaced starter relay, as 12v to the selenoid leg of relay plug engages starter and turns engine. But still no luck from the key switch.

Any ideas?? All suggestions greatly appreciated.

Thanks,

Tee
 

·
Registered
Joined
·
104 Posts
Discussion Starter #3
Don't think its the ground as the starter works fine when jumped at the selenoid.

Just doesn't work when you turn the key.

Could it be an issue with the Neutral Safety Switch??
 

·
Registered
Joined
·
1,280 Posts
Don't think its the ground as the starter works fine when jumped at the selenoid.

Just doesn't work when you turn the key.

Could it be an issue with the Neutral Safety Switch??
If you jumpstart from the starter you are bypassing the battery. so yes it could be ground or possitive for that matter.
its a place to start.
and as Kyle said look at the other components.
:cheers:
 

·
Registered
Joined
·
104 Posts
Discussion Starter #6
Perhaps I miss communicated, by jumper I meant jumped from the positive to the selenoid with a screwdriver on the starter/selenoid. Sorry..... I will check the NSS today.
 

·
Registered
Joined
·
6,178 Posts
Perhaps I miss communicated, by jumper I meant jumped from the positive to the selenoid with a screwdriver on the starter/selenoid. Sorry..... I will check the NSS today.
Ya I would say that is a fair place to start, let us know what happens.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #8
And the winner is......NSS.....

Unplugged the whip & pulled the plug underneath where I could adjust the switch position and test until I got it right. Put it back together and started right up.

Now to fix the pinhole in the radiator.....umph....

Thanks for all your input.

Tee
 

·
Registered
Joined
·
1,122 Posts
And the winner is......NSS.....

Unplugged the whip & pulled the plug underneath where I could adjust the switch position and test until I got it right. Put it back together and started right up.

Now to fix the pinhole in the radiator.....umph....

Thanks for all your input.

Tee
Crank the heep let it get up to temp then crack a egg in the rad. it will plug the hole with out harm to the motor.
 
1 - 9 of 9 Posts
Top