Jeep Cherokee Talk banner
1 - 15 of 15 Posts

·
Registered
95 grand Cherokee Laredo limited Quadra-trac
Joined
·
9 Posts
Discussion Starter · #2 ·
95xj 4.0 grand Cherokee Laredo temp gauge only works when pressing on the brake ? Stumped have new sending unit on back of block grounded and pegs out but only when I press the brake
 

·
Super Moderator
Joined
·
11,244 Posts
check your grounds. pull the dash cluster, and disconnect and reconnect the connectors on the back
 

·
Registered
95 grand Cherokee Laredo limited Quadra-trac
Joined
·
9 Posts
Discussion Starter · #4 ·
check your grounds. pull the dash cluster, and disconnect and reconnect the connectors on the back
How do you disconnect the harness under the vent at the back of the dash. It’s a bear any special holding push clips or is it squeez n pull? Also would you know where the cluster grounds the sheet metal screw above the hood release has no grounds to it. Unfortunately I’m dealing with someone else’s trial and error. There is a blue wire labeled electronic brake which is bare on the end no connection there.
 

·
Super Moderator
Joined
·
11,244 Posts
i believe the connectors are squeeze n pull. it's tight. Electronic brake wire was probably connected to an auxiliary brake the PO had for trailer brakes. The PO left the wire but took the controller. You may have a 7 pin trailer connector next to your hitch. BTW you have a 95 ZJ, not an XJ. Grand Cherokees are ZJ's. I included a test for your temp gauge.


Font Rectangle Circle Number Pattern
 

·
Registered
95 grand Cherokee Laredo limited Quadra-trac
Joined
·
9 Posts
Discussion Starter · #6 ·
i believe the connectors are squeeze n pull. it's tight. Electronic brake wire was probably connected to an auxiliary brake the PO had for trailer brakes. The PO left the wire but took the controller. You may have a 7 pin trailer connector next to your hitch. BTW you have a 95 ZJ, not an XJ. Grand Cherokees are ZJ's. I included a test for your temp gauge.


View attachment 230328
i believe the connectors are squeeze n pull. it's tight. Electronic brake wire was probably connected to an auxiliary brake the PO had for trailer brakes. The PO left the wire but took the controller. You may have a 7 pin trailer connector next to your hitch. BTW you have a 95 ZJ, not an XJ. Grand Cherokees are ZJ's. I included a test for your temp gauge.


View attachment 230328
Yes zj my fat fingers pressing x. I’ll probe d9 and let you know what I find after tomorrow’s grind your input has been appreciated it’s making sense now.
 

·
Registered
95 grand Cherokee Laredo limited Quadra-trac
Joined
·
9 Posts
Discussion Starter · #8 ·
This was my first inclination as well. Ground strap from block to firewall is missing and no ground on the sheet metal screw above the hood release no wires there period to start with. I like this zj no rust to speak of and for the most part it’s clean. The input on this is much appreciated
 

·
Registered
95 grand Cherokee Laredo limited Quadra-trac
Joined
·
9 Posts
Discussion Starter · #11 ·
Yes far better than tearing down the whole harness
Yes far better than tearing down the whole harness
Update: traced all grounds and replaced accordingly. Traced power @ harness cluster pin assembly. Inspected every millimeter of the printed circuit on cluster. I put a jumper on ground screw @ gauge temp and grounded it to the dash bracket. It worked.
 

·
Registered
Joined
·
4 Posts
How do you disconnect the harness under the vent at the back of the dash. It’s a bear any special holding push clips or is it squeez n pull? Also would you know where the cluster grounds the sheet metal screw above the hood release has no grounds to it. Unfortunately I’m dealing with someone else’s trial and error. There is a blue wire labeled electronic brake which is bare on the end no connection there.
Pop the front trim panels (few screws at very bottom. Then Pull the Guage Cluster straight out by hand! I believe the insulation is flaking off your copper wires, allowing them touch the "other" wires. Motor Mounts still good???
 

·
Registered
95 grand Cherokee Laredo limited Quadra-trac
Joined
·
9 Posts
Discussion Starter · #13 ·
Pop the front trim panels (few screws at very bottom. Then Pull the Guage Cluster straight out by hand! I believe the insulation is flaking off your copper wires, allowing them touch the "other" wires. Motor Mounts still good???
I’ve had the cluster out numerous times everything checks except ground at the unit. Mounts are good as well. I can tear that cluster out in 5 min. Connection is a bear though
 
1 - 15 of 15 Posts
Top