Jeep Cherokee Talk banner
1 - 3 of 3 Posts

Registered
Joined
7 Posts
Discussion Starter · #1 ·
Hello,
I've had a long turn over time for about 6 months now. It's an intermittent problem, but the first start of the day is usually good then the rest are bad. I've replaced my Fuel Injectors, Spark Plugs, Cap, Rotor, and Wires, Ignition Coil, Coolant Temperature Sensor, and PCV valve. Those last 3 parts "fixed it" for about a week each then it would go back to it's old games. My fuel rail is pressurized and priming the fuel pump a few times prior to starting doesn't make a bit of difference (I don't think it's the fuel pump or valve that's the problem). I do occasionally get a code for a misfire on cylinder 2, but that usually pops up after driving a bit, not on start-up. Has anyone seen this before or have any ideas what it might be?
Thank you in advance 馃
 

Registered
Joined
6 Posts
Hello,
I've had a long turn over time for about 6 months now. It's an intermittent problem, but the first start of the day is usually good then the rest are bad. I've replaced my Fuel Injectors, Spark Plugs, Cap, Rotor, and Wires, Ignition Coil, Coolant Temperature Sensor, and PCV valve. Those last 3 parts "fixed it" for about a week each then it would go back to it's old games. My fuel rail is pressurized and priming the fuel pump a few times prior to starting doesn't make a bit of difference (I don't think it's the fuel pump or valve that's the problem). I do occasionally get a code for a misfire on cylinder 2, but that usually pops up after driving a bit, not on start-up. Has anyone seen this before or have any ideas what it might be?
Thank you in advance 馃
i also have a 1999 jeep cherokee and had your problem was a week crank position sensor.
 
1 - 3 of 3 Posts
Top