Jeep Cherokee Talk banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,316 Posts
Discussion Starter #1
All my vents work except the defroster again. There is no disconnection behind the front bumper. It works fine when on 1 but any higher and the door closes up. Pulled the radio once and jiggled the arm and it worked fine for awhile but now its doing it again. Anybody have this problem before whats the deal ? Gettin tired of pullin the radio. By the way my radio wont play a cd anymore if anybody has one pulled and tired of looking at it I will pay for shipping.:dunno:
 

·
Registered
Joined
·
81 Posts
I have similar problems on my 99. on mine the defrost generally will only clear off the drivers side of the windshield and if I put it on floor only I still get air coming out of the defrost vents. I have yet to get any solid answers how to fix it other than replacing the heater box.
I am hittin the junkyard tomorrow and gonna tear some XJ dash's apart just so I can get a first hand look at how the dash comes apart before I start tearing into mine.
 

·
Registered
Joined
·
608 Posts
Have you checked all the vacuum connections behind the dash and whatnot?
As for the radio, just buy one at Best Buy or somewhere, the factory one is kinda pointless. If you want stock again try the JY, they usually have tons of those things around...

Oh, BTW.... Fill out your vehicle information in your profile, it helps the rest of us know what's going on without having to ask a ton of questions, esp. when it comes to year-, or era- specific details...
 

·
Registered
Joined
·
1,316 Posts
Discussion Starter #6
All the connections are fine . Once i pulled the radio and jiggled the arm around and it was fine for awhile. I prefer the 96 and earlier ones with the sliders. The vacuum ones on my 99 S10 had problems too. Why cant they just uses the metal wires instead of vaccum.
 

·
Registered
Joined
·
1,316 Posts
Discussion Starter #7
Oh yeah also replaced the whole control section once and it was a waste of time.
 

·
Retired Moderator
Joined
·
7,287 Posts
I've been dealing with this problem since May as well. I'm finally going to be tinkering with it this week. I've found several write-ups on JF that talk about possible fixes and such for this problem, so hopefully one or a combination of them will get this solved. I'll report back with some (hopefully positive) details.
 

·
Registered
Joined
·
1,316 Posts
Discussion Starter #9
Cool I am gettin tired of dealing with it too. The only one that gives me problems is the defroster.
 

·
Registered
Joined
·
81 Posts
I went to the junkyard yesterday and found a 98 classic with the dash halfway removed. it was the only 97+ in the yard so I felt blessed. I spent a while tinkering with it lookin around before I went back and got my tools and just started removing screws. partially for experience, partially just so I had a large supply of spare interior trim screws. I always seem to drop one or 2 when I am workin in the grass at my moms.
anywho I grabbed the vaccum canister for the defrost vent while I was there. now I just need to decided if I have enough patience to tear MY dash completely out of the jeep to fix it. it pisses me off every time I drive it in snow so with winter weather predicted for the next 2 days I have a feeling I know what my plans include this weekend
 

·
Registered
Joined
·
1,316 Posts
Discussion Starter #11
Well let me know and post a pic of the vaccum canister in the dash only if its different than the one the size of a dixie cup with a vac port and a arm. I think the arm linkage by the defroster always binds up some how.
 

·
Registered
Joined
·
81 Posts
nope its the one you just described but there are 3 of them. one for each vent (defrost, dash, and floor) I only grabbed the defrost one because thats the only one I seem to be having trouble with.
 

·
Registered
Joined
·
1,316 Posts
Discussion Starter #13
Well I never replaced just the vaccum switch. Let me know if it works or not. I still think the linkage sticks.
 

·
Registered
Joined
·
81 Posts
agreed. I think my problem is in the linkage as well but I couldnt get the entire heater box out like I wanted in the time allotted so I just grabbed the vaccum canister because it was the only thing removable separately
 
1 - 15 of 15 Posts
Top