Jeep Cherokee Talk banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So while investigating another unrelated issue, I decided to pull my cam position sensor to get little peek down into the engine. The only thing is, I neglected to mark it's position before I pulled it. Anyone know an easy way to get it reinstalled and in time?
 

·
Premium Member
Joined
·
9,260 Posts
Tom, we need more info here. What year, model and engine for instance. And did you mean distributor instead of CPS?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Derp, sorry. '04 GC 4.0. It just has the cam position sensor that goes to the PCM.
 

·
Registered
Joined
·
7,030 Posts
Ok, so 2004 (WJ) which would have been coil on plug, no dizzy. I've never pulled the cps in my 01 XJ, but I was under the impression it was pretty hard to get to, let alone see down in. Tom, pics would help here.
 

·
Premium Member
Joined
·
9,260 Posts
Which engine, 4.0 or 4.7
 

·
Registered
Joined
·
7,030 Posts

·
Premium Member
Joined
·
9,260 Posts
It is on the upper driver side bell housing. FSM shows it to be a regular hex bolt mounting it, so that is a plus
 

·
Super Moderator
Joined
·
10,444 Posts
He is not talking about the crank sensor, it's a cam sensor. it's in place of the distributor.
 

·
Registered
Joined
·
7,030 Posts
well hell I'm confused.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
So I figured it out. There are only 2 ways it can go in, and when I looked closely I found very faint marks from the friction plate that holds it in position. Lined it up the first time, and it didn't start. turned the little flathead things 180 degree and reinstalled. She fired right up.
 

·
Registered
Joined
·
7,030 Posts
Glad to hear it!
 
1 - 12 of 12 Posts
Top