Jeep Cherokee Talk banner

1 - 20 of 20 Posts

·
Registered
Joined
·
3,211 Posts
Discussion Starter #1
well its on,, I try disconecting the bat and turning back on and its still there, the alt gauge is low and well this is new, bc comming back from the wheeling trip all was good, yesterday I power wash it and today I turn on and see this,, what could it be?
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #2
ok now I left it running for a lil while and the alt level went up to the regular place, but the check engine is still on.. what could it be?
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #3
ok its low again, everytime I start it up its low and now the belt squeels
 

·
Squirrel Master
Joined
·
1,383 Posts
Hmm... could've got water in your distributor when you power washed it. Could've swamped your alternator a little too. I've had some hiccups with mine after power washing it. It should clear up once everything dries out.
 

·
Retired Moderator
Joined
·
7,287 Posts
You may have gotten something soaked when you powerwashed it (possibly the alternator), and possibly could've damaged it.

You could always try to tighten the belt. It may be possible that your belt is slipping, causing your voltage to drop, and the belt to squeal. If your running the AC or the Heat, and the belt squeals when you press on the gas then definately tighten it.

To reset the computer properly, disconnect the negative battery wire/terminal and touch it for 30 seconds to the positive terminal of the battery. This will reset the CPU and clear your codes.
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #6
its a damage alternator took it in for replacement.. should have the xj back by about 2pm
 

·
Premium Member
Joined
·
11,624 Posts
Welcome to the world of hardcore 4wheeling where it's "you play, you pay!" ;) Glad ya found the problem. :)
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #8
but have an other one now, well not sure if its a problem,,,

when I turn off the xj the engine has a poping noice, like making popcorn inside of the valve cover, what can that be,, im going to star by changing the oil tomorrow
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #10
Change the oil and let us know what the color is, ps you should have changed the alt yourself :D
I know, but I did not had time to do it, :thumbdown:
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #12
the mech took even more than your first time LOL
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #14
what should I look at the oil color? what color it should not be, the PO change it right before selling it to me, so it has about a month or so,,,
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #16
okok I hope it come black LOL, can this be check on the dip stick?
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #18
I will
 

·
Registered
Joined
·
3,211 Posts
Discussion Starter #19
oil look fine,, replaced the filter, and put in 5 qt Castrol GTX high milage 10 w40 with a quart of Lucas Oil Additive

but I still have the popcorn sound,, I think it comes from the manifold side, when its on it does not pop, only when its off

can it be the mud around the exhaust?
 
1 - 20 of 20 Posts
Top