Jeep Cherokee Talk banner

1 - 16 of 16 Posts

·
Squirrel Master
Joined
·
1,383 Posts
Discussion Starter #1
After about an hour of my 3-hour drive home yesterday, my speedometer suddenly went haywire. I was cruising at about 70, when my speedometer jumped up to 80, then 85, then down to 70, then back to 80, then down to 60, and back to 80, down to 70, and so on and so on. Basically, the thing's going apeshit. If I'm cruising at 45 (12:00 on the XJ's speedo) it'll jump from anywhere between 30 and 50, and just go back and forth, jerking and jumping around like crazy. Is something loose? Shorting out? Fuse? Wire? What causes this? Everything else works fine. :dunno:
 

·
Premium Member
Joined
·
11,624 Posts
After about an hour of my 3-hour drive home yesterday, my speedometer suddenly went haywire. I was cruising at about 70, when my speedometer jumped up to 80, then 85, then down to 70, then back to 80, then down to 60, and back to 80, down to 70, and so on and so on. Basically, the thing's going apeshit. If I'm cruising at 45 (12:00 on the XJ's speedo) it'll jump from anywhere between 30 and 50, and just go back and forth, jerking and jumping around like crazy. Is something loose? Shorting out? Fuse? Wire? What causes this? Everything else works fine. :dunno:
You are warping through time and space. That's freakin awesome man. I envy you. How did you build such a machine?


Back to reality, try pounding the dash with your fist. I had the same issue with my TJ, plus all the gauges go dead and when i pound it in anger, it fixes itself. if it stops or does something different, then you've narrowed it down to the instrumental panel.
 

·
Short Bus Motorsports
Joined
·
1,786 Posts
Not sure with out looking it up, proabaly either a speedocable or a Vehicle speed sensor. Not sure what the 96 has
 

·
Squirrel Master
Joined
·
1,383 Posts
Discussion Starter #4
You are warping through time and space. That's freakin awesome man. I envy you. How did you build such a machine?


Back to reality, try pounding the dash with your fist. I had the same issue with my TJ, plus all the gauges go dead and when i pound it in anger, it fixes itself. if it stops or does something different, then you've narrowed it down to the instrumental panel.
I did just install the time circuits and flux capacitor, but I have yet to get the Jeep up 88 mph. I think I need 4.88 gears. :p

All the other gauges work fine, (and by others I mean gas... stupid dummy lights). Everything else in the dash seems to be working - radio, lamps, shift light, etc. I'll give it a haymaker on the way home from work though. :D
 

·
Squirrel Master
Joined
·
1,383 Posts
Discussion Starter #6
I haven't had a chance to yet. I'll get in there and see what I can find this afternoon. Taking the dash apart... yay. :brickwall:
 

·
Squirrel Master
Joined
·
1,383 Posts
Discussion Starter #10
I didn't get a chance to tear into it today. Had too many errands to run and ran out of daylight. I'm gonna look more into it tomorrow and see if I can find a diagram of how the sensors are setup before I do anything - give myself a road map of sorts. When I start taking things apart I'll let you know what I find. I know a guy with a YJ that had the same problem, but he never fixed it, just left it like that for 4 years. :brickwall:
 

·
Registered
Joined
·
31 Posts
Check the connections at the speed sensor on the back of the tranfer case.Unplug it and check for grease/crap in the connection.Spray it out with some sort of cleaner and make sure it's clean.Squirt alittle grease in it before you plug it back together.
 

·
Squirrel Master
Joined
·
1,383 Posts
Discussion Starter #13
I unplugged the speedo wires at the t-case and cleaned off the male and female connectors. Didn't appear to be dirty, but who knows. Put the connector back on and wiggled it in tight, speedo works once again. :cheers:
 

·
Registered
Joined
·
27 Posts
ive had the same problem for a year now!!its funny watching it bounce around.funny cause recently it started bouncing when i was stopped and gave it gas,kinda like a tach.but this past week it doesnt work at all till its warmed up so im glad i read this thread.
my friend actually has a video clip of it tweaking out.i gotta get it from him,its hilarious
 
1 - 16 of 16 Posts
Top