Jeep Cherokee Talk banner

1 - 20 of 34 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
1999 Jeep cherokee xj, I seen the fuel filters are part of the fuel pump assembly innthe tank, my question is can I add a hose clamp style filter externally? Being as though it's a high pressure system.
 

·
Premium Member
Joined
·
9,829 Posts
Welcome to the forum
Yes you can
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Preciate it, i replaced one injector (all the store had in stock) now it cranks without the aid of starter fluid but whenever i get down on it bogs and tries to die, thats what got me to thinking filter
 

·
Premium Member
Joined
·
9,829 Posts
How long since your O2 sensors have been replaced

Also you might have a clogged catalytic converter
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
Cats cut out i recently bought it, it was a play toy for the previous owner, really couldnt tell you on the O2 sensor but if that could cause it i will replace that also
 

·
Premium Member
Joined
·
9,829 Posts
Probably never changed and making you run lean
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
Ill pull the O2 tomorrow and check on it, thank you for the help I'll let you know what happens
 

·
Premium Member
Joined
·
9,829 Posts
O2 sensor was cut??
 

·
Registered
Joined
·
23 Posts
Discussion Starter #11
The wires to the O2 sensor is cut off its just a mud toy so I guess the previous owner cut them ill send video
 

·
Premium Member
Joined
·
9,829 Posts
Did you get a check engine light? No wonder it wasn't running right. Get a new one and wire it up. Then take your battery cables off, touch them together, install them and then start it and let the ECM learn all over again. These Jeep ECMs are kind of stupid, so it takes a little while
 

·
Registered
Joined
·
23 Posts
Discussion Starter #13
No check engine light but Im not sure if that works on the dash the rpm mph and thermostat work but not fuel guage so thats a toss up but ill grab one today and get back to you
 

·
Premium Member
Joined
·
9,829 Posts
OK, if you get it installed I am sure it will run better. Are you getting black smoke out the tail pipe now? That would not be surprising with no data from the sensor
 

·
Premium Member
Joined
·
9,829 Posts
Good opportunity to teach them about cars while you are at it, if they are old enough
 
  • Like
Reactions: Arconger

·
Registered
Joined
·
23 Posts
Discussion Starter #17
Replaced 02 sensor and it runs better but spitting and sputtering is still there gonna clean the iac in a little bit
 

·
Premium Member
Joined
·
9,829 Posts
Did you do the battery trick?
 
1 - 20 of 34 Posts
Top