Jeep Cherokee Talk banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, I have a 1999 Grand Cherokee Laredo. In the last few months it has started stalling while I am driving. It has happened while I was driving on the interstate and while slowing down to stop. Usually I can shift into neutral, crank and shift back into drive and resume. A few times I have has to stop for a couple of minutes then it would crank. I want to sell it but would like to take care of this first. And suggestions or advise would be greatly appreciated. Thanks so much.
 

·
Registered
Joined
·
3,990 Posts
Hi Connie, welcome to the forum. :hi:

As far as the stalling issue, I personally have no yet experienced the stalling issues. However, it seems to be a trend on the forum lately because I see this issue popping up like crazy all of a sudden. If you haven't had a chance to check any of the stalling threads, I see that the vehicle speed sensor may be the culprit. It is located on the rear upper part of the transmission. If you have no check engine light, I would start in that location. :)
 

·
Registered
Joined
·
1,468 Posts
Welcome to ct from Ohio!
 

·
Registered
Joined
·
4 Posts
Hi Connie, welcome to the forum. :hi:

As far as the stalling issue, I personally have no yet experienced the stalling issues. However, it seems to be a trend on the forum lately because I see this issue popping up like crazy all of a sudden. If you haven't had a chance to check any of the stalling threads, I see that the vehicle speed sensor may be the culprit. It is located on the rear upper part of the transmission. If you have no check engine light, I would start in that location. :)
.

I appreciate your response. I did see a post about crank position sensor and fuse. Is that the same as vehicle speed sensor? Is there a way to test if that's it? Or just as easy to go ahead and replace?
 
1 - 8 of 8 Posts
Top