Jeep Cherokee Talk banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
New to the forum, so I read some before asking. I saw some other issues with mileage with no real fixes.

The issue(s) with my son's 99 cherokee sport; we've had it about 2 years now and it is totally stock. Mileage has never been good, 15-16 MPG at first. Then about 6-8 months ago the check engine light came on and it idled high 2000-2500 RPM at start up for 5 to 10 seconds. Then idle fine; however mileage dropped to 12 MPG.

After checking codes and determined the TPS was bad...replaced TPS, check engine light off, mileage still sucks.

Had tune-up $450 worth and mileage still sucks 11-12 MPG and that was with a trip to LBI, NJ for volleyball tournement. Now high idle is back 2500 RPM, and sometimes 3000 RPM for a couple of seconds, then the engine sounds like it starves for fuel and chuggs and RPM drop to 700-800 RPM's then fast idel again. This happens for 3 or 4 cycles 30-60 seconds and then idle smooths out and runs fine.

After putting it in gear, (4 sp. auto) and hitting the gas, the engine boggs down (sounds and feels like it is not getting enough fuel). This happens two or three times then all is well and it runs like a top until next start up.

Took it back to shop and they replaced the idle motor something??? If anything it got worse. Going back to the shop Friday. Any ideas, suggestions, help would go a long way.
 

·
Premium Member
Joined
·
1,629 Posts
New to the forum, so I read some before asking. I saw some other issues with mileage with no real fixes.

The issue(s) with my son's 99 cherokee sport; we've had it about 2 years now and it is totally stock. Mileage has never been good, 15-16 MPG at first. Then about 6-8 months ago the check engine light came on and it idled high 2000-2500 RPM at start up for 5 to 10 seconds. Then idle fine; however mileage dropped to 12 MPG.

After checking codes and determined the TPS was bad...replaced TPS, check engine light off, mileage still sucks.

Had tune-up $450 worth and mileage still sucks 11-12 MPG and that was with a trip to LBI, NJ for volleyball tournement. Now high idle is back 2500 RPM, and sometimes 3000 RPM for a couple of seconds, then the engine sounds like it starves for fuel and chuggs and RPM drop to 700-800 RPM's then fast idel again. This happens for 3 or 4 cycles 30-60 seconds and then idle smooths out and runs fine.

After putting it in gear, (4 sp. auto) and hitting the gas, the engine boggs down (sounds and feels like it is not getting enough fuel). This happens two or three times then all is well and it runs like a top until next start up.

Took it back to shop and they replaced the idle motor something??? If anything it got worse. Going back to the shop Friday. Any ideas, suggestions, help would go a long way.
Has the throttle body been cleaned?
Has the fuel pressure been checked?

If you have a temp gauge do you think it is reading correctly?
Have the O2 sensors ever been changed?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
The shop I have gone to for years is top notch. "Complete tune up and checked everything". No codes at this time, at least no check engine light. Like I said it goes back in Friday and they are going to put the old Idle Control Motor/Sensor? back. I was told the TB was cleaned and all filters were fine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
They didn't mention that, but I replaced that a couple of weeks ago, when I got the codes. When I replaced the TPS the check engine light went off and to date has not come back on. I am assuming that if the new TPS went bad I would get the codes again. I will bring it up on Friday though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Got my son's Cherokee back from the shop yesterday...late. Didn't have time to check it out. They replaced the TPS (the one I put in from Quadratec was bad), found "a small intake leak (tightened bolts) and industrial strenght injector cleaner. Purring like a kitten this morning.
 
1 - 7 of 7 Posts
Top