Jeep Cherokee Talk banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2001 jeep cherokee 4.0 6cyl. 4x4. I was driving it one day and the temp shot up and I pulled over maybe a 1/4 of a mile down the road and it died on me. I poped the hood and antifreeze was on the entire engine as the raiator cap was not tight. I towed it to my house and it wouldnt run for anything after that. I did a compression test and determined that it was a blown head gasket. I got the jeep back from a guy that replaced the head gasket and it was missing really bad and would die when trying to idle. I then took it to my garage and parked it and it wouldnt run after that. I took the valve cover off and realized that the valves were all really tight, I loosened them and then once again got compression and it began to run. The computer codes out that the TPS is bad. I also have a problem of the jeep not shifting out of second gear. Is that ground related or is there a problem with my computer?? Any thoughts on this would help me out thanks. You can email me and [email protected] or post on here. Thanks
 

·
Registered
Joined
·
608 Posts
DYOUNG, DYOUNG, DYOUNG... I can relate to all those problems (they all happened to me over the last week, except I don't have a funky head gasket)...
For some reason, these Jeeps will stall out when you get them cooking real hot... Mine does it all the time when I shoot it to 260*.
If you're getting a TPS code, clean that thing... Mine sticks now after freezing up from my latest overheating ordeal.
If you wanna check, just disconnect the battery for like 20 mins... to see if it resets the codes and shifts.
 

·
Premium Member
Joined
·
413 Posts
I would first start off with the TPS issue, adjust it and if that doesnt work then replace it.

Can you adjust and TPS out of a 2001, I don't think you can... You will have to replace it.

Also is this in the right area seems like stock chat to me. Or where ever
 

·
Registered
Joined
·
6,178 Posts
Can you adjust and TPS out of a 2001, I don't think you can... You will have to replace it.

Also is this in the right area seems like stock chat to me. Or where ever
Thats a good question, I dont know if it can be adjusted.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I am sorry I dont make this my life, I may have put it in the wrong forum I am sorry to dissappoint you. To those others, I replaced the map sensor and TPS and it still has a little but of trouble cranking over, and idling. Is the other senson on the throttle body a low idle sensor?? There are 3 sensors on it one being the map the other the TPS and the third..... I am unsure. Would that fix my idle problem and my starting problem. Thanks for all your input and any help you can give me.
 

·
Registered
Joined
·
6,178 Posts
I am sorry I dont make this my life, I may have put it in the wrong forum I am sorry to dissappoint you. To those others, I replaced the map sensor and TPS and it still has a little but of trouble cranking over, and idling. Is the other senson on the throttle body a low idle sensor?? There are 3 sensors on it one being the map the other the TPS and the third..... I am unsure. Would that fix my idle problem and my starting problem. Thanks for all your input and any help you can give me.
No you were right we just did a bit of reconstruction around here.

Better define idle problems, what exactly is it doing?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Thanks man. Well it has a little trouble starting you kinda have to crank on it for awhile....almost as if it is trying to build compression. Once it starts it will run and idle pretty good but once it warms up a bit the motor kinida misses a bit and quivers, and when you drive it down the road it has a tendancy to die when comming to a stop or turning. I drove it 5 miles yesterday and it only died at one out of 8 stop signs and once out of a few rolling turns. It did better, then I drove it about 50 miles from the garage I had it in to mine and it ran fine temp and oil pressure were great, had all kinds of power. It would run 70mph down the highway with no proble,got it home and let it set and idle and it was idleing, but rough. I replaced the map sensor and the TPS but there is that 3rd sensor on the throttle body, I am unsure of what it is, I heard that it was a low idle sensor....any truth to that I am unsure. Or if that would fix my problems.
 

·
Premium Member
Joined
·
413 Posts
Thanks man. Well it has a little trouble starting you kinda have to crank on it for awhile....almost as if it is trying to build compression. Once it starts it will run and idle pretty good but once it warms up a bit the motor kinida misses a bit and quivers, and when you drive it down the road it has a tendancy to die when comming to a stop or turning. I drove it 5 miles yesterday and it only died at one out of 8 stop signs and once out of a few rolling turns. It did better, then I drove it about 50 miles from the garage I had it in to mine and it ran fine temp and oil pressure were great, had all kinds of power. It would run 70mph down the highway with no proble,got it home and let it set and idle and it was idleing, but rough. I replaced the map sensor and the TPS but there is that 3rd sensor on the throttle body, I am unsure of what it is, I heard that it was a low idle sensor....any truth to that I am unsure. Or if that would fix my problems.
Okay well this is sounding alot like CPS issues now.

Try this quick fix. Unplug it and then replug it back in a few times. Your connection is a lil degraded. This was a problem I had a few months back and it is now running great. HTH

The connector side is located at the rear driver's side of the valve cover.



If this doesn't work your CPS could be bad.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Thanks man, I put a new crank sensor on and it didnt change it so I took it back, but that was before I even had it running. I will try unplugging it and if that doesnt fix order one again. Is there by chance a fuel pressure sensor on the back of the fuel rail that could be bad or no??
 
1 - 10 of 10 Posts
Top