Jeep Cherokee Talk banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Banned
Joined
·
27 Posts
Discussion Starter #1
HA! I knew that would get your attention. LOVE JEEPS FOREVER!

When I started this whole endeavor, Initially I tried everything. It is driveable now but there are issues.
The EVAP solenoid clicked before. Now it does not and there is no voltage going to it. The solenoid itself is fine bc I manually tested it. I am getting a
P0443 code from that.

I replaced both o2 sensors b4 I found the prob to be the head gasket. I believe these new guys were fouled by antifreeze coming from the cracked head and bad gasket. I am getting codes P0130 and P0136 for these. Can't get rid of them. Can I clean them?

It's skipping on acceleration and not changing gears when it should. Im getting the TPS code (P0121), Which I'm guessing might have a little something to do with it.

It's also giving me the P0705. I do not have reverse lights. According to other forums, these two are related. Any experience with this? Found an article on cleaning the NSS (Jeepin.com :: NSS fix) I'll do it tomorrow since Im snowed in. :rofl:

Last, but not least. Before I knew what the BIG problem was (cracked, warped head), I tried in vain to adjust the timing. Little did I know, that this was a no-no in a coil pack truck. I loosened the set screw and hold down and fiddled with the -what I thought to be- the distributor. Not so. Does this have to be reset by a pro? I followed chiltons and reset the CPS.
 

Attachments

·
Web Wheeler
Joined
·
2,573 Posts
Yeah i would take that second picture off before kyle sees.....
 

·
Web Wheeler
Joined
·
2,573 Posts
No, but we try to be courteous. If you are all into that sort of stuff, i'm plenty sure there are other forums for you.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top