Jeep Cherokee Talk banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Heat doesn't blow hot, AC blows cold but sometimes just shuts off but works again when your turn the AC off and then on. Might have a coolant leak/problem but that only seems to be when the AC is on. Any thoughts on that? Also it came missing most of the passenger side mirror and i cant seem to get it off so i can put on the new one (but i have not got around to looking too deep into the manual so i might look stupid for that one). other than that it has run beautifully, 4.0 with automatic (not happy about the auto but i got a good price), aftermarket satellite radio installed, 150000 miles but the speedo seems a bit fast so i was wondering if this could be a bigger number than it should be. is that common at all? it certainly does not look like a 150000 mile car, interior is perfect and everything is very clean, will post pictures when i get a chance.

thanks -Brad
 

·
Registered
Joined
·
642 Posts
I'm no mechanic, but i'll take a stab at it. The no heat problem could be from a bad thermostat. I had one go bad in the open postion so it never allowed the car to warm up, therefore no hot water to run to the heater. The AC thing, mabey a short in the connection behind the switch? As far as the leak that only happens when the AC is on, that's most likely due to condensation building up on the AC Condenser, which then drains off onto whatever is below it. Iv'e even seen cars that you'd swear had a hole in the radiator when it turns out they only had the AC on. Hope this helps :)
 

·
Registered
Joined
·
470 Posts
as for the heat, if your engine gets up to temp (210deg) normally and you have at least a minimal amount of coolant in your system, than your heater core is probably plugged up, flush it with a garden hose. If you arent getting up to temp properly than go with thermostat 1st. And as for the leak, if its small, dont worry about it, youll spend more time and effort tracking it down and dealing with it than you would just living with it. If its large, and your having trouble finding it use a pressure tester. Check the clutch on the A/C, might possibly be finicky, or bad electrical connection? Good luck!
 

·
Registered
Joined
·
127 Posts
I've got the same problem with my blower having issues sometimes it'll stop then I thump it and itll go again it's really a pain but I think my problem is the switch behind the blower is nice and rusted but also with my heat I had bought a heater core to replace mine cause I thought mine was shot it turned out to just be a busted valve I can take a pic of the valve I replaced so you can check yours
 
1 - 4 of 4 Posts
Top