Jeep Cherokee Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey everyone, I am new here but need a bit of help. My boss has a 2002 4.7 Grand Cherokee with Quadratrack or whatever its called...the awd system. My question is this. He thought his power steering pump was shot cause there was fluid just draining right out, when I looked at the vehicle I saw that it was coming from the top hose that connects to the pump itself. Its right behind the belt. We went to Autozone, Car Quest, and Advanced and all of them are telling us that they don't make the hose we need. Does anyone have the part number for this item or does anyone know where we can get one. We are going to try the dealer tomorrow and see what they have to say. I had this same issue on my 5.2 93' Dakota and we went right down and bought the hose. This was 5 years back though. The hose that we were given is the hose that goes from the steering gearbox down, this is not the one we need. If anyone can help it would be awesome. Thanks in advance guys! :rock:
 

·
Registered
Joined
·
3,805 Posts
I had the same problem about a year ago...it's a crap hose design, and there is a newer style hose available. I believe there is a service bulletin released about it, but don't remember for sure. I don't remember the part number, but a Jeep parts dept can give you that, then you should be able to get an aftermarket replacement if you don't want to buy the factory part at whatever auto parts store you like to shop at. Sorry I can't give you any more info then that...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
the pressure hose is not even connected to the pump so thats not it but it may be the other one.
 

·
Registered
Joined
·
1 Posts
I had the same problem - ordered the hose from every parts place in town and they all had the same "wrong" part. I finally went to the dealer who told me about a note in the computer that even the dealer part requires you to change the pump end of the hose. The other end goes to the hyd fan motor. A new dealer hose will fit on the fan motor end but requires a change on the pump end. They were oout of stock so I still have not seen it, but based on this info, i now realize that all those aftermarket parts are probably correct but will require a new fitting to be installed in the pump to replace the fitting that is currently there. If I can get my hand on the hose, I will update this post. One thing is for sure - this hose if a common failure and they all fail about 6 to 8 years old. It is a common dealer replacement part and I am surprised all the aftermarket places don't sell it with the required fitting.
 
1 - 6 of 6 Posts
Top