Jeep Cherokee Talk banner
1 - 20 of 20 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 · (Edited)
Hey, all.
My 1996 XJ has a problem. It will crank, start, run for a second or two, then stall. It does this consistently. It will not stay running. I have been through the forums and cannot find this exact complaint. He is what I've done:
1. checked and cleaned grounding points.
2. replaced crank sensor.
3. replaced cam sync sensor.
4. replaced cap, rotor, plug wires, and spark plugs.
5. replaced fuel pump (47psi at the rail).
6. replaced ECU.
7. new fuel injectors.
8. no vacuum leaks.
9. new fuel filter.


There is no VATS.

Does anyone have any thoughts?
 

·
Premium Member
Joined
·
10,426 Posts
I would like to know what the fuel pressure is when it stalls
 

·
Premium Member
Joined
·
10,426 Posts
does it restart immediately?
 

·
Premium Member
Joined
·
10,426 Posts
Have you pulled the distributor?
 

·
Premium Member
Joined
·
10,426 Posts
Is the rotor in the 4 o'clock position at top dead center?
 

·
Premium Member
Joined
·
10,426 Posts
What brand of sensor did you use?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #12 ·
I found a possible issue. In order to determine if it is an issue, I need to look at a wiring diagram. Does anyone have a wiring diagram that illustrates the ignition switch connector in the steering column?

1996 Cherokee Country 4.0 AW4
 

·
Registered
Joined
·
12 Posts
Hey, all.
My 1996 XJ has a problem. It will crank, start, run for a second or two, then stall. It does this consistently. It will not stay running. I have been through the forums and cannot find this exact complaint. He is what I've done:
1. checked and cleaned grounding points.
2. replaced crank sensor.
3. replaced cam sync sensor.
4. replaced cap, rotor, plug wires, and spark plugs.
5. replaced fuel pump (47psi at the rail).
6. replaced ECU.
7. new fuel injectors.
8. no vacuum leaks.
9. new fuel filter.


There is no VATS.

Does anyone have any thoughts?
You probably have wrong cold crank battery size
 

·
Registered
Joined
·
3 Posts
Hey, all.
My 1996 XJ has a problem. It will crank, start, run for a second or two, then stall. It does this consistently. It will not stay running. I have been through the forums and cannot find this exact complaint. He is what I've done:
1. checked and cleaned grounding points.
2. replaced crank sensor.
3. replaced cam sync sensor.
4. replaced cap, rotor, plug wires, and spark plugs.
5. replaced fuel pump (47psi at the rail).
6. replaced ECU.
7. new fuel injectors.
8. no vacuum leaks.
9. new fuel filter.


There is no VATS.

Does anyone have any thoughts?
Fuel pressure the power to the Fuel pump is not constant . Or there is shit inside the tank fill the tank if it rungs longer drop the tank drain the tank the bag is not connected the pump can't pump the fuel of you have crap in the tank. How to you fill the gas tank if you are off rode. Yeah o shit the gas container I wonder what's inside it.gas o and a candy bar wrapper. O maybe paint ball o maybe it's a gum ball o maybe it's old and was sitting. Maybe the e gas cap is not venting maybe you should take it to a mechanic and pay the man to fix it .
It's a 25 year old jeep. .
 

·
Super Moderator
Joined
·
11,132 Posts
The diagram did help me to figure out everything is correct with the ingition switch. Do you have any wiring diagrams for the rest of the power distribution?
Yes, pages and pages of diagrams. DM me your email and I will send them to ya.
 
1 - 20 of 20 Posts
Top