Jeep Cherokee Talk banner

1 - 7 of 7 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter #1
When I put on my lift I was not able to get the lower sway bar link bolts out. I bent the bracket on the axle trying. Is there a secret to getting them out? They are 55 torx. I used a breaker bar but never got them to move. I want them out to make quick disconnects.
 

·
Registered
Joined
·
3,691 Posts
They are not threaded in, lol! They have a torx's head but they are pressed in and have splines. Easiest way to get out is to use a ball joint press or some type of puller of that sort. If you're lucky you might be able to whack them out with a big sledge. Goodluck! :thumbsup:

edit: Also, another method is to cutoff the torx's head flush with the bracket, Then stack washers on the threaded side and tighten down the nut and it will slowly pull the bolt right out. Plus its free!
 

·
Registered
Joined
·
6,917 Posts
Hmmm, I was wondering this exact thing, but I thought later I found that they did thread in....guess not. We beat on mine for a good while, then gave up. I am making disconnects also, but I have found a new method. However....If I do get them out.....oh I don't know what I wanna do with this yet.

Thanks for the info Leon.
 

·
Registered
Joined
·
1,099 Posts
best way is to just cut the torqs head off the splined bolt then add washers or a socket that fits over it and put the nut back on the bolt and tighten till it pulls itself out.......dont dick with pullers or anything and you will be on your way very quickly and stress free
 

·
Registered
Joined
·
643 Posts
best way is to just cut the torqs head off the splined bolt then add washers or a socket that fits over it and put the nut back on the bolt and tighten till it pulls itself out.......dont dick with pullers or anything and you will be on your way very quickly and stress free
I wish I would have thought of this...
 

·
Registered
Joined
·
6,917 Posts
I torched mine out years after this thread. It can't fight me when its liquid.

But the reason for swinging back through this thread was that recently I loaned a guy some tools to reconnect the swaybar links on his wife's TJ. It didn't have any splines on the bolts. And I believe they were factory because it had the correct big torx head on it, but no splines. Weird. I told him I couldn't believe he had even gotten it apart.
 
1 - 7 of 7 Posts
Top