Jeep Cherokee Talk banner

1 - 20 of 21 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
So today I did my exaugst manifold and everything whent off with out a hitch (thank God). But when I started my Jeep and looked at the temp gauge to see if it was warmed up it hadent moved from 100°F yet but my oil pressure was normal so I drove it arround. A good solid 20min whent by still not off 100. I have everything plugged in to its respective spots and it still isent moveing does anyone know what could be causeing this to happen? Could my temp sensor have whent bad or what? If anyone has any idea please help me!
 

·
Marshmallow
Joined
·
3,780 Posts
Check the plug on the sending unit on the thermostat housing and one on the back of the head toward drivers side between firewall and head. One of those probably became unplugged.
 

·
Where am I???????????????
Joined
·
3,729 Posts
ldub100 said:
Check the plug on the sending unit on the thermostat housing and one on the back of the head toward drivers side between firewall and head. One of those probably became unplugged.
I told ya so :D lol
 

·
Registered
Joined
·
155 Posts
Discussion Starter #5
It was the plug in the back of the block that wasent plugged in! Now everything becides my alarm makeing my tail and marker lights flash works haha!!!!! I am happyer than a child opening his Christmas presents!!!!!!!
 

·
Marshmallow
Joined
·
3,780 Posts
Isn't it nice when it's the simple things?
 

·
Super Moderator
Joined
·
10,301 Posts
pretty sure thats it, the front one on the t-stat is what the ECM uses to control the fans. The rear is for the gauge, Had to change mine when i went from idiot lights to a gauge.

:thewave:
 

·
Registered
Joined
·
2,263 Posts
So what if you have the mechinal fan, what does front sensor do? Not trying you up on triva but i have the mechinal fan and would like to know
 

·
Where am I???????????????
Joined
·
3,729 Posts
SHELBYGT said:
So what if you have the mechinal fan, what does front sensor do? Not trying you up on triva but i have the mechinal fan and would like to know
We all have a mechanical fan. Im just going out on a limb but, i think the computer reads the temp from the front sensor and turns the e-fan on and off as needed. Right?
 

·
Super Moderator
Joined
·
10,301 Posts
From all that I can find, you are correct, your GC has only the mechanical fan.

:dunno:

Maybe someone else can chime in.
 

·
Registered
Joined
·
2 Posts
temp gauge in console not working

2004 Jeep Grand Cherokee, V6. Temp gauge just stays right in the middle, hot or cold engine. New thermostat & radiator. Checked connector at thermostat and the number of connectors on the back left side attached at the firewall. ???
 

·
Premium Member
Joined
·
9,190 Posts
I think your temp sending unit needs replaced
 
1 - 20 of 21 Posts
Top