Jeep Cherokee Talk banner

1 - 13 of 13 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
ok....when i am driving slow in a strait line....its quiet,when i slightly tyrn the wheel left or right i can hear a mellow creaking noise....doesnt seem to affect anything at momentdriving wise...but what is it?
 

·
Registered
Joined
·
151 Posts
Discussion Starter #3
possible....im getting some stuff done thurs at my 4x4 shop,ill pass that on.could it be something inside my wheel,like some bearings?
 

·
Registered
Joined
·
6,178 Posts
possible....im getting some stuff done thurs at my 4x4 shop,ill pass that on.could it be something inside my wheel,like some bearings?
I would check the mount first, why dont you just tighten it up:dunno:
 

·
Retired Moderator
Joined
·
7,287 Posts
I'm going to say u-joints, even though it can definately be one of many things. I don't think it's the trackbar just because it tends to make a louder noise when it shifts around. May as well also check your lug nuts, as they could've loosened up and cause your tires to shift when you turn the wheel (not to mention also while driving).
 

·
Registered
Joined
·
151 Posts
Discussion Starter #6
kyle i checked the mounts and etc seems ok, thanks for the troubleshooting help tho.....thanks for your imput....any other tips feel free to say more, thanks guys

i know my front right u joint is troubled i was told.....although im not 100% sure exact niose location.seems to be wheel but i can be incorrect.

ill have everything you guys are saying looked at......
 

·
Web Wheeler
Joined
·
2,573 Posts
Go under there and grease everything with a zerk fitting. It probably isn't what the noise is, but it's worth a shot.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #8 (Edited)
i just had all new RE upper/lower adj control arms tossed in 3 weeks ago.....but ill grease the rest, also.......it only does it 70% of time...i went to show my coworker the trouble and it didnt do it.....hehe typical.but its there...noticed it daily lately
 

·
Registered
Joined
·
151 Posts
Discussion Starter #9
i know this can be hard to just say....so thanks for your advise anyways
 

·
Registered
Joined
·
6,178 Posts
kyle i checked the mounts and etc seems ok, thanks for the troubleshooting help tho.....thanks for your imput....any other tips feel free to say more, thanks guys

i know my front right u joint is troubled i was told.....although im not 100% sure exact niose location.seems to be wheel but i can be incorrect.

ill have everything you guys are saying looked at......
What was the process in checking the mount?


Also make sure your LCA's are tightened to spec (110lbs?) frame side.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #13
when wheel is turned there is a small popping at times.......had a buddy walk beside frontend when i did this.....seems my front right u joint is failing
 
1 - 13 of 13 Posts
Top