Jeep Cherokee Talk banner

1 - 19 of 19 Posts

·
Registered
Joined
·
488 Posts
Discussion Starter #1
well just introducing myself... my name is alex have a 98 xj with 3 in lift and a check engine light..
 

·
Registered
Joined
·
3,211 Posts
welcome to CT from PR,
 

·
Registered
Joined
·
488 Posts
Discussion Starter #5
well im cuban and someone random person called me that and it stuck.. i do have a question that i need help with..i have a 98 with an 01 engine(inl6) and wen my check engine is on it runs like a champ.. so i went and checked the code and it said it was my o2 i replaced both with o2 for a 01.. then i turned the check engine light off and it ran like poop. as soon as it came on again it run like a champ again... any ideas?
 

·
Registered
Joined
·
3,211 Posts
keep it on, and just brake the lil bulb :D
 

·
Registered
Joined
·
488 Posts
Discussion Starter #7
lol thats what im doing..:) dont have much of a choice noone has any idea why... it like sputters backfires threw the intake i guess then takes off like a race car
 

·
Premium Member
Joined
·
1,629 Posts
well just introducing myself... my name is alex have a 98 xj with 3 in lift and a check engine light..
:rofl: I love that introduction.

Are you thinking the lift has something to do with the check engine light? :dunno:

Welcome.

Okay I read some more of the posts. I had a O2 sensor go bad, the upstream sensor. Anyway the engine was running very lean and had a very rough idle. Now that was WITH the check engine light on. It may be that your O2 sensor isn't making very good contact, or the new one is bad. Of course it is possible that now the computer is throwing out new codes. The only way to find out is to see what code it is now.
 

·
Registered
Joined
·
488 Posts
Discussion Starter #11
well i installed the o2 and checked it the next day and it said the o2 were bad....i have noticed that their is two different intake manifolds for the 4.0 i have the more square looking one..would that effect it in any way..and most 2001 i have seen have the more rounded one..
 

·
Premium Member
Joined
·
1,629 Posts
well i installed the o2 and checked it the next day and it said the o2 were bad....i have noticed that their is two different intake manifolds for the 4.0 i have the more square looking one..would that effect it in any way..and most 2001 i have seen have the more rounded one..
Did you clear the codes after you installed the new O2 sensor?

The replacement O2 sensor, did it have the connector on it, or did you have to cut the old one off and splice it on the new O2 sensor?
 

·
Registered
Joined
·
488 Posts
Discussion Starter #14
no i just unplugged and plugged back in and yes i cleared the code...wont do it again..really frustrating how i cant figure out what to do. new cap, rotor, wires, plugs..
 

·
Registered
Joined
·
872 Posts
Welcome to CT from COS!!:cheers:

I'm diggin the CEL mod, looks sharp!! LOL!!
Sounds like you have a sence of humor, you'll fit in nicely here!!
 

·
Registered
Joined
·
1,234 Posts
you forgot to mention who told you about the forum!!!
 
1 - 19 of 19 Posts
Top