Jeep Cherokee Talk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
My 2000 WJ (Limited, V8, automatic, 2WD) was running fine for the first 700 miles of the trip, then suddenly began to run very rough and then kept dying if I didn't keep the rpm way up.

I pulled over, flipped the key 3 times and got the following codes:

p0201, p0202, p0203, p0204, p0207, p0208 (Injector or wiring to injector on cylinders 1-4, 7 and 8);

p0303, p0307 (cylinders 3 and 7 misfiring)

p0121 (TPS / throttle position sensor)

p1685 (SKIM (Smart Key Immobilizer Module) invalid key)

What could possibly make this happen?

The only previous problem I'd experienced related to any of this, was an occasional p0307 that would pop up for a while, then go away again for a while, and an occasional slight surging of RPM when sitting in idle.
 

·
Marshmallow
Joined
·
3,780 Posts
Sounds like the ECM may have taken a dump and lost the data. May have to visit the stealer to get it straightened out. I would first try disconnecting the battery cable for about half an hour to see if it might reset itself. Good luck and keep us posted.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thanks for the post - after 2 days I was beginning to think I wouldn't get a response.

I did disconnect it for about 5 minutes, but will try a longer disconnect in case it needs that much time.

I don't have much $ so I'm hoping it's not an ECM programming (or replacement) issue, but we'll see. Since there was some minor surging at idle before this happened, I am going to try a few cheap things like cleaning the AIC (air intake controller) and replacing the TPS. I may also clean the throttle body if I can figure out how ;-) We'll see what happens.

Nice looking XJ in your avatar pic btw! I have the 2000 GC, but also have a 2000 XJ. Despite some problems here and there I really like the XJ.
 

·
Marshmallow
Joined
·
3,780 Posts
Thanks, the TPS can cause the surging or rough idle. There are a few threads on here that tell how to test the TPS. If that is the issue, get the OEM TPS from the dealer. A lot of times, the aftermarket sensors don't work right.
 

·
Registered
Joined
·
12 Posts
My 2000 WJ (Limited, V8, automatic, 2WD) was running fine for the first 700 miles of the trip, then suddenly began to run very rough and then kept dying if I didn't keep the rpm way up.

I pulled over, flipped the key 3 times and got the following codes:

p0201, p0202, p0203, p0204, p0207, p0208 (Injector or wiring to injector on cylinders 1-4, 7 and 8);

p0303, p0307 (cylinders 3 and 7 misfiring)

p0121 (TPS / throttle position sensor)

p1685 (SKIM (Smart Key Immobilizer Module) invalid key)

What could possibly make this happen?

The only previous problem I'd experienced related to any of this, was an occasional p0307 that would pop up for a while, then go away again for a while, and an occasional slight surging of RPM when sitting in idle.
Fuel pump
 
1 - 5 of 5 Posts
Top